6G Celicas Forums

Welcome Guest ( Log In | Register )

> Question about brake caliper
post Aug 17, 2020 - 2:36 PM
+Quote Post
CheesyLobster



Enthusiast
****
Joined Jul 19, '04
From Los Angeles, CA
Currently Offline

Reputation: 2 (100%)




Hi there, looking for some guidance.

I recently broke a lug stud on my front passenger side. I got a replacement and took off the wheel, caliper, and caliper bracket in order to remove the disc brake and install the new stud. That part went fine, but when I went to put the caliper back on, it seemed really tight. The wheel does not seem to move freely, and upon driving, my braking power seems reduced.

- Did I do something wrong? Is it possible something got misaligned, or I needed to do X before putting it back on? I did not apply brake cleaner or lube; could that fix it? Or does my caliper just need to be replaced?
- I did not disconnect the break line; it is possible I have too much pressure in the line and I need to bleed the brakes a bit?

- If I do replace the caliper, should I also just go ahead and replace the pads and discs? Is this a simple bolt on or do you need special measuring tools? I don't think they have ever been replaced but seemed to be working ok.

Thanks for the help!

This post has been edited by CheesyLobster: Aug 17, 2020 - 2:38 PM

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: January 17th, 2021 - 11:00 AM