6G Celicas Forums

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Celica st205 wrc motor cutting power and boost problem
post Aug 24, 2016 - 1:58 AM
+Quote Post
empite

Enthusiast
*
Joined Nov 14, '14
From greece
Currently Offline

Reputation: 0 (0%)




Hello,
im dealing a problem 7-8 days now first of all
The problem symptoms changes couple times
When i was hit boost with 2 and 3 gear the car did a cut like the speed limiter ... like motor died...(so hard cut) well changed to cutting like no fuel or something like that...and now it goes 5 rpma and starts lagging like rpm limiter...
What i did
1)changed fuel filter with bigger and new
2)changed spark plugs with new and i checked all spark coils everything okay
3) i checked from ecu to igniter and igniter to distributor never cutted power from there
4)i checked volts from fuel pump works at 8 and 9 volts and 5 amber..are these volts low?..expect this, when i turn the key to "on"before start engine the pump doesn't starts for Little like "vrouuuuum"and stop because im sure before months did it...
5) i haven't check the fuel pressure yet...
6)i changed the map with other and i checked it with polymeter it works...
7)the turbo gauge from cluster never goes to 0 it goes little bit down from zero when i turn key to "on"
i press all the way down the gas after 3000rpm and when it goes to 4 and half until 5 makes cuts like rev limiter but the boost in cluster is full...is there anything wrong with tvsv or the vsv? I have and video but i dont know how to share it
post Aug 24, 2016 - 6:54 PM
+Quote Post
Smaay

Enthusiast
*****
Joined Dec 8, '03
From Lancaster CA
Currently Offline

Reputation: 6 (100%)




sounds like boost cut, how much boost are you making.

9 volts is good for idle. the resistor is active at low load. at high load its bypassed and the the fuel pump gets 12V


--------------------
2001 Celica GT-S Turbo
1997 Supra TT 6speed
1997 Celica 3MZ/1MZ swap
1990 Celica All-Trac
post Aug 25, 2016 - 6:58 AM
+Quote Post
empite

Enthusiast
*
Joined Nov 14, '14
From greece
Currently Offline

Reputation: 0 (0%)




QUOTE (Smaay @ Aug 24, 2016 - 7:54 PM) *
sounds like boost cut, how much boost are you making.

9 volts is good for idle. the resistor is active at low load. at high load its bypassed and the the fuel pump gets 12V

Nono... 9 volt maximum idle and higher rpms..im waiting now until tomorrow adapter for manometer to check the fuel pressure its not boost cut ,i did the map test like Toyota's manual says..i installed glycerine's gauge witb T adapter on map and they saying press all the gas on 2nd gear at 3000rpm and more and if sayin maximum 16.7 psi and minimum 11 if i remember right the tvsv and map are work right...i checked today lambda sensor the gas pedal sensor too foe air temp on butterfly..i need yo install an halimeter or wideband to see if the car has low fuel or high fuel...i need to take out injectors rail and injectors too...i dont know what is going on

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: August 20th, 2018 - 8:07 PM