Help - Search - Members - Calendar
Full Version: Question about Dr. CAI
6G Celicas Forums > 6th Generation Celica > Engine/Transmission/Maintenance
Delta_Phoenix
I have an aluminum Dr. CAI and it rubs agains the motor mount. I didn't notice it until recently and by then the motor mount had eaten a hole almost all the way through the piping. I didn't know what else to do so I put about 8 layers of heat resistant tape over the hole. Does anyone have any suggestions on what to do?

Also, the CAI bounces around because of the coupling and I can never get it tight enough to stop it from doing that. What could I do to solve that problem?
t96f
Rubbing-I'd say try adjusting the position, if not possible glue a junk of rubber in that spot..
bouncin around- find a means ie zip tie or similar to hold it still
Blackcelliman
The only part of my DR. CAI that touches is the top of my transmission. It barely touches it though, so you might want to play around with different angles to get it right where it should be. It took me a whole afternoon to get it assembled, but it's right where it's supposed to be.
Delta_Phoenix
I've tried adjusting the CAI to the position that your's is in, but it just won't go that way. I have mine pushed up into the coupling at the manifold pretty far because if I only push it in a little it bounces around really bad.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.