Help - Search - Members - Calendar
Full Version: Problem with a battery draw
6G Celicas Forums > 6th Generation Celica > Engine/Transmission/Maintenance
kloudkicka
hey guys, so my car has been having alot of issues, right now i have a battery draw and i have no idea whats causing it, everytime i start my car i have to sit there and crank it for awhile until it gets going, and everything inside restarts, like my clock and my deck, somethings not keeping the charge on my battery. i've already disconnected my sub and amp and i've already disconnected my alarm and it still happens. Alternator has been checked and its working fine, i hear it could be maybe a bad starter but hoping someone here can help, thanks
The_enD
What's your voltage while cranking and at idle, and off?
How does it start with a fresh battery?
Box
If the battery has a dead cell it'll drain itself.
kloudkicka
Im not sure wat the voltage is, but a shop I took it to said everything reads normal, and a fresh battery is still the same thing, I put 3 new batterys in my car and all of them ended up draining, its so frustrating
Box
There's a way to find what's causing it. Use a multi-meter and set it up for reading out amperage draw. Once that's set up you can start pulling fuses until the draw drops, therefore finding the source.
kloudkicka
okay cool, lets see what i can find

QUOTE (Box @ Apr 21, 2013 - 2:06 AM) *
There's a way to find what's causing it. Use a multi-meter and set it up for reading out amperage draw. Once that's set up you can start pulling fuses until the draw drops, therefore finding the source.

This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.