Help - Search - Members - Calendar
Full Version: 5SFE swap electrical issues. Please help.
6G Celicas Forums > 6th Generation Celica > Engine/Transmission/Maintenance
brandon702bmx
Everything is good now thank you!
Bitter
If you're getting a single tap then the starter solenoid is at least getting power, pull the starter and bench test it before you run out and get one, if it bench tests fine then either it's too weak to spin the engine or the power feed or ground feed is too weak to give it the power to spin the engine.
brandon702bmx
Turned out to be the stupid fuse box giant plug. The little brace that holds it in place has to be clipped and up for the electrical connections to work. Car started... now unfortunately... my fans will not kick on and it overheats.
Smaay
use a test light, the big wire that is bolted to the starter is constant battery power. the black plug is key switched power. pull out the plug and stick the test light into it. turn the key to start and see if the test light comes on. if it does then you are getting proper power to the starter. if it does not, then you have an electrical issue. check relays and fuses
brandon702bmx
QUOTE (Smaay @ May 24, 2017 - 10:31 PM) *
use a test light, the big wire that is bolted to the starter is constant battery power. the black plug is key switched power. pull out the plug and stick the test light into it. turn the key to start and see if the test light comes on. if it does then you are getting proper power to the starter. if it does not, then you have an electrical issue. check relays and fuses

Thank you! I did. It happened to be something very stupid and minor but frustrating.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2018 Invision Power Services, Inc.