6G Celicas Forums

Welcome Guest ( Log In | Register )

3 Pages V   1 2 3 >  
Reply to this topicStart new topic
> HID Kit Install 56K BEWARE!!, HID's from culpable
post Oct 19, 2006 - 2:17 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




Hey guys as you all know we recently had a GB for JLM HIDS. I got my package today and installed them. Here is my Install, (just remember that eveyones install will be at their own risk and opinions)

First off, you will want to unplug the battery.
IPB Image

Next you will want to remove your stock bulbs and set them aside in case you somehow mess up the HIDs or want to use them later.
IPB Image
IPB Image
IPB Image

Then youll want to get the HID ready for install, you will want to pull it out of the protective plastic covering. BE EXTEMELY CAREFUL TO NOT TOUCH THE BULB.
IPB Image
IPB Image

Once the bulb is in place and in socket you can prematurely mount the Ballast where you want. (my bulbs were a little hard to get in so be careful and have patience)
IPB Image

Next connect the bulb wires to the ballast sockets. Make sure they snap conpletely.
IPB Image

After you have all the ballast connected on both sides (RH, and LH) you will need to run the resistance wires to your liking. I ran mine from the left bulb above the engine by the stock strut bar.
IPB Image

You will want to connect the ground wire to a suitable spot in your engine bay. (sorry didnt think i needed a pic of this step. Also the fuse has red wire coming out that needs to be connected to the positive pole of your battery. (Make sure it is connected to the battery if not, the HID's will not work.)

After you have everything installed and connected, double check to make sure everything is how you want and secure the ballast with the sticky tape included and use zipties if necessary.

Then clean up and turn on the lights, they may flicker at first but will soon warm up.
IPB Image

I am extremely happy with the results.

ENJOY!!
post Oct 19, 2006 - 2:37 PM
+Quote Post
Toyoca



Enthusiast
***
Joined Mar 14, '06
From Mary Land
Currently Offline

Reputation: 0 (0%)




sweeet. looks good. i think... pictures are kinda huge to see well
post Oct 19, 2006 - 2:52 PM
+Quote Post
Slick



Enthusiast
***
Joined Jan 10, '06
From Mozambique, Africa
Currently Offline

Reputation: 8 (100%)




Nice! you made it sound too easy.


--------------------
IPB Image

"Remember, amateurs built the ark and professionals built the Titanic. But revolutionaries built the Celica!"- Me
post Oct 19, 2006 - 2:57 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




SOrry about the picture size, i was in a hurry to get these uoloaded. I will see if i can do anything about the size.

Enjoy
post Oct 19, 2006 - 3:10 PM
+Quote Post
Chanh55

Enthusiast
*****
Joined Jun 29, '03
Currently Offline

Reputation: 0 (0%)




Nice pics. You need to resize those things.
post Oct 19, 2006 - 4:38 PM
+Quote Post
6strngs



Enthusiast
*****
Joined May 12, '06
From Wilmington, NC
Currently Offline

Reputation: 45 (100%)




Sweet. now I know how to put mine in biggrin.gif I'm trying to get my motor mounts back in first though so I can get the car running first (this seems more important to me for some reason, lol) but if I have enough time, I might do this later today/tonight. how long did it take you start to finish?


--------------------

94 GT - Sold -------- 69 Pontiac Lemans - Sold
88 Alltrac - Sold ---- 04 WRX - Sold
00 GT-S - Sold ------ 91 Miata - project/drift car
95 GT - Sold -------- 96 GT - New Daily Drive
post Oct 19, 2006 - 5:02 PM
+Quote Post
chacha

Enthusiast
*****
Joined Dec 29, '05
From Fresno
Currently Offline

Reputation: 12 (100%)




i didn't even use that long cord thing...just the ballast...were we suppose to use that too? anybody had problem like me posted on the GB HID KIT forum post....

This post has been edited by chacha: Oct 19, 2006 - 5:04 PM
post Oct 19, 2006 - 5:13 PM
+Quote Post
airfron



Enthusiast
***
Joined Jul 31, '05
From Southern California
Currently Offline

Reputation: 7 (100%)




looks good Mario thumbsup.gif


--------------------
post Oct 19, 2006 - 5:20 PM
+Quote Post
LewFX



Enthusiast
*****
Joined Jan 28, '05
From Redondo Beach, CA
Currently Offline

Reputation: 86 (100%)




long cord the resisters?


--------------------
IPB Image
post Oct 19, 2006 - 6:22 PM
+Quote Post
tomazws



Enthusiast
*****
Joined Oct 30, '04
From So Cal
Currently Offline

Reputation: 13 (100%)




Is that the dryest / safest place to mount the relay?


--------------------
post Oct 19, 2006 - 6:29 PM
+Quote Post
tomazws



Enthusiast
*****
Joined Oct 30, '04
From So Cal
Currently Offline

Reputation: 13 (100%)




I thought this is really funny... talk about Engrish...


IPB Image


--------------------
post Oct 19, 2006 - 9:42 PM
+Quote Post
chacha

Enthusiast
*****
Joined Dec 29, '05
From Fresno
Currently Offline

Reputation: 12 (100%)




how many connectors are on the core?...i have two adapters, one cap, and the (+) and (-)... is this correct....if so, im not connecting the core correctly, because i don't have another cap to enclose the adapter for the OEM plug...can someone show or pinpoint where each of the caps and adapter goes to which....

IPB Image

This post has been edited by chacha: Oct 19, 2006 - 9:43 PM
post Oct 19, 2006 - 10:18 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




The top block looking thing is the resistance or resistor, The two cords with the yellow wrapped around it are the connectors that need to be connected to the ballasts. The other cord is the power supply it needs to be connected to one of the stock OEM light sockets. If you have any other questions feel free to ask.
post Oct 19, 2006 - 10:25 PM
+Quote Post
chacha

Enthusiast
*****
Joined Dec 29, '05
From Fresno
Currently Offline

Reputation: 12 (100%)




aren't there two OEM light sockets?, i only have one to cover...the other OEM socket will be exposed... smile.gif but i do appreciate your help
post Oct 19, 2006 - 10:43 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




Yes, there are two OEM sockets, so you have to connect the power connector to one of the OEM sockets. I just taped over my other OEM socket that i did not use.
post Oct 19, 2006 - 10:56 PM
+Quote Post
chacha

Enthusiast
*****
Joined Dec 29, '05
From Fresno
Currently Offline

Reputation: 12 (100%)




you mean the two terminals (+) anmd (-) have to be plugged into the OEM socket? i must be driving you nuts man, thanks for your help!

This post has been edited by chacha: Oct 19, 2006 - 10:57 PM
post Oct 19, 2006 - 11:14 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




IPB Image

The blue color is the power outlet which needs to be plugged into here.

IPB Image

That is where you need to plug the power outlet.

and the red circle is where the ballast need to be connected to.
post Oct 19, 2006 - 11:16 PM
+Quote Post
chacha

Enthusiast
*****
Joined Dec 29, '05
From Fresno
Currently Offline

Reputation: 12 (100%)




i got that part...it's just the other OEM that im worry about...i don't have X2 of the one with the blue circle to connect to the other OEM socket...sorry for the confusion...i also try your method of blocking the other oem socket and covering it up, but only one headlight shines...other is dead...when turned on

This post has been edited by chacha: Oct 19, 2006 - 11:19 PM
post Oct 19, 2006 - 11:18 PM
+Quote Post
CelicaGT04



Enthusiast
***
Joined Nov 22, '05
From Mesquite, Texas
Currently Offline

Reputation: 0 (50%)




Yeh i know, the kit only comes with 1 power outlet connected to the resistor. So you will have 1 OEM socket that is not connected to the ressistor.
post Oct 20, 2006 - 11:05 AM
+Quote Post
LewFX



Enthusiast
*****
Joined Jan 28, '05
From Redondo Beach, CA
Currently Offline

Reputation: 86 (100%)




i got them in, but what do the extra 2 cords with metal poking out go?


--------------------
IPB Image

3 Pages V   1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: October 23rd, 2019 - 6:44 AM