6G Celicas Forums

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> 4th gene 3sgte, anyone with the pinout wiring diagram??
post May 11, 2010 - 5:29 AM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




Hey there guys.My mates having trouble starting his newly swapped 4th gen 3sgte.we figured there's sumfin wrong with the wiring.anyone with the ECU wiring diagram and the pinout diagrams?we swapped the same motor in a AE100 sprinter and it runs like a beast.need the wiring diagrams for the 6gc.please help....
post May 11, 2010 - 7:00 AM
+Quote Post
pitcelica

Enthusiast
*
Joined Jan 28, '07
From Québec, Canada
Currently Offline

Reputation: 1 (100%)




ST215 engine wiring harness to ECU diagram :

http://www.users.on.net/~fivebob/Images/GenIV/ST215W-1c.jpg

ST215 ECU pinout :

http://www.users.on.net/~fivebob/Pages/pins.xml

Good luck with the swap!

Sam
post May 11, 2010 - 10:26 AM
+Quote Post
easternpiro1



Enthusiast
*****
Joined Feb 1, '05
From Charlotte NC
Currently Offline

Reputation: 14 (100%)




wow a sprinter?! pics?!

and thanx sam, added to my pile of info! (gotta holler at u later)



--------------------

QUOTE (Galcobar @ Oct 15, 2008 - 2:44 AM) *
You want power but have no money. That's a problem.

Cheap. Reliable. Fast. Pick two.
post May 11, 2010 - 6:22 PM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




@ pitcelica:THANK YOU SOOOO MUCH!!!!!


@easternpiro1: kinda untidy setup though...front wheel and waiting for 4wd conversion once the timing at the front wheels are done.a sti killer.real light.

http://i671.photobucket.com/albums/vv73/ka...kk/Image112.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image127.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image126.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image122.jpg
post May 12, 2010 - 9:35 AM
+Quote Post
easternpiro1



Enthusiast
*****
Joined Feb 1, '05
From Charlotte NC
Currently Offline

Reputation: 14 (100%)




QUOTE (kavy @ May 11, 2010 - 6:22 PM) *
@ pitcelica:THANK YOU SOOOO MUCH!!!!!


@easternpiro1: kinda untidy setup though...front wheel and waiting for 4wd conversion once the timing at the front wheels are done.a sti killer.real light.

http://i671.photobucket.com/albums/vv73/ka...kk/Image112.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image127.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image126.jpg

http://i671.photobucket.com/albums/vv73/ka...kk/Image122.jpg

wow nice! surprised to see how simillar to a camry it looks


--------------------

QUOTE (Galcobar @ Oct 15, 2008 - 2:44 AM) *
You want power but have no money. That's a problem.

Cheap. Reliable. Fast. Pick two.
post May 14, 2010 - 12:49 AM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




hey guys.m sorry to bother u all again but we're having trouble with the celica setup.thanx alot 4 the ecu pinouts n wiring diagrams once again.but now we're confused on where the 4 lugs goin out of the ecy goes to.actually the lugs were cut out wen we got the motor so is there anything which will help us in identifying where all the wires go??

This post has been edited by kavy: May 14, 2010 - 12:50 AM
post May 14, 2010 - 10:58 AM
+Quote Post
pitcelica

Enthusiast
*
Joined Jan 28, '07
From Québec, Canada
Currently Offline

Reputation: 1 (100%)




Please post pics, it will be easier for us to answer you.

Do you mean the grounds lugs (intake manifold ground straps (2x))?

Sam
post May 23, 2010 - 3:37 PM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




ok guys.for the pics.i told ma cuzzie to get it coz ma camera got effin stolen.but he hasn't come around yet.
about the four lugs that i mentioned,it seems to be the ones for the dash accessories.anyone wif the wiring diagram for tat??
we worked with the wiring given by Sam bowdown.gif and it didn't seem to start.thinking there was sumfin wrong wif the motor,we started dismanteling it.taking out the intercooler 1st,we cranked the motor and WALAH!the motor started but for a short while and to add to that,the turbo became a fountain!got the windshield and the roof covered in oil.this oil seemed to have entered the combustion chamber during transportation in which the motor must've tilted and oil seeped in thru an open valve.ok,so after cleaning it and putting the motor back together we tried to start it again.it cranked but did not fire.checked the wiring,all good.we fink it has sumfin to do wif the 4 lugs(mentioned earlier) that come out of the ECU has sumfin to do with it.it's coz when we give the motor fuel manually,it fires.guy's so sorry for being a total headache but this is totally killing us.so please,if u have ANY information on the any of the wirings in this swap,please share.i'd be on cloud 9 if ne1 knows wea to get the caldina GT-T service repair manual.i figure it's got like everything.
sorry once again and thanks in advance..
post May 25, 2010 - 10:02 PM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




Hey there guys.some more in4 on the swap.
i think i know what the problem is.you see,the motor that came had an auto gearbox and the ECU was for the same.i was goolgeing and stumbled upon this
file:///C:/Users/Kaushik%20Prasad/Downloads/ST215%20not%20starting%20unless%20gas%20is%20given%20thru%20intake.htm#top
seems like the guy on that forum went through the same problem we're facing.now i can't contact him on how to bridge the ECU to make it think its in park mode so the injectors can inject fuel for the engine to start.there is already current in the injector wires and all the other places(thanks once again sam thumbsup.gif ).
now the problem is that of locating the Park or either the Neutral pinout on the ECU.it's not given in the pinout diagrams or the wiring harness to ECU diagram.
help anyone??? frown.gif
post May 26, 2010 - 8:42 PM
+Quote Post
pitcelica

Enthusiast
*
Joined Jan 28, '07
From Québec, Canada
Currently Offline

Reputation: 1 (100%)




Send me your email and I'll give you my notes on how I did my hybrid harness (Excel file). I'm using an auto ECU too and I do not have connected any automatic related wire to the ECU. Only the necessary wires are connected. Give me your email address via PM.

The only problem I have with the auto ECU is that it do not have any kind of deceleration fuel cut because automatic tranny let the engine near idle speed on a deceleration situation instead of a manual tranny that keep the RPM steady with a high vacuum state (no fuel needed in this high vacuum state... so more fuel economy).

Anyway, it's only a temporary state because I want to re-convert it to Megasquirt as soon as my MS2 chip is repaired. Then, I'll have full control over deceleration fuel-cut, sequential fuel injection, sequential ignition timing, launch control, boost control etc.

Sam

post May 27, 2010 - 2:45 AM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




Hey guys.i got the pic of the lug.Sam,the in4 u gave will be used tomorrow.thanx a heap man.but i guess everything else is up and ready to run.its just the wires on this lug that needs to be wired right.sorry for the pic quality.phone camera.



This post has been edited by kavy: May 27, 2010 - 7:57 PM
post May 30, 2010 - 7:37 PM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




PROBLEM SOLVED!!!!!
turns out wiring and everything was alright but the injectors were bathed in oil.cleaned those,and walah!!:D:D:D
thanx alot Sam!!!wudn't have achieved this without ur help:)smile.gifsmile.gif
(I'll post pics once my exams are over)
post Jul 3, 2010 - 10:37 AM
+Quote Post
SlvrCelica09



Enthusiast
***
Joined Jan 10, '09
From Burtonsville, Maryland
Currently Offline

Reputation: 1 (100%)




exams over yet? lol I think you should post some good pics and a how to on how you did it.. not many are doing a 4th 3sgte swap. This thread could be very helpful. Once you do that.. Stickyyyy


--------------------
THIS IS WHERE WE HOLD THEM!
Still trying to find the cure for ST205 asthma..
6gc.net's outlaw vigilante because im a LEADER not a follower.
post Jul 4, 2010 - 5:20 AM
+Quote Post
kavy



Enthusiast
*
Joined Aug 8, '09
From Fiji
Currently Offline

Reputation: 0 (0%)




OMG!thanx for the reminder buddy smile.gif .Ok to start things off, i was brought into this setup when most of the work was done to it as the engine was already sitting in the car but from what i know,the 4th gene 3sgte came with an auto gearbox to fit in a SS1 celica with auto 3sfe motor.the guys that put in the motor managed to get a manual tranny off a 3sge motor and it works just fine.i've asked the guy to join the forum and he said he will soon so any questions related to how the motor fit and what were the problems encountered will be best answered by him.from what i know,the motor fit in without much modifications.my cuzzie with the 3sgte sprinter put in a manual tranny off a diesel motor,2C-III to be exact.it works fine and an added advantage as i was told was that the transmission had longer ratio's when compared with the original tranny that comes with the motor.ALL the wiring information that was needed for the swap is on this thread already posted by Sam a.k.a pitcelica.

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: October 14th, 2019 - 4:41 AM