6G Celicas Forums

Welcome Guest ( Log In | Register )

> Hooptie 6gc
post Aug 7, 2017 - 10:29 PM
+Quote Post
sircalebwhite

Enthusiast
*
Joined Jan 12, '15
From Cambridge, Minnesota
Currently Offline

Reputation: 0 (0%)




Hey guys! After a long while of not having a 6gc, I finally found one! It's quite the interesting car. It's a 1994 GT liftback 5 speed. Power everything and an aftermarket alarm with fob. Seats are in almost new condition, interior is in great sape, a few tiny discrepencies in the dash but nothing bad. Advan 17" rims, lowering springs, some weird muffler on it, Kouki tails and SSIII grill on the facelift bumper, not sure what the skirts are and kinda have mixed feelings on them. Would much rather have OEM skirts but we'll see how the ones that are on look after a paint job. Anyways here's some history.. A few owners ago she was getting some good treatment. Aftermarket goodies, JDM goodies, the works. Then she started getting neglected. Sitting outside in the hot SoCal sun, probably being beat on, and even a little crash in the front.. They threw on a new bumper, hood, and fenders and continued to drive it until they got bored of it which is where cha boi comes in. After some talk with the owner I checked it out and noted some things.. Body isn't too bad but clearly needs a paint job. Engine runs great. Idles nice, starts fine. But the drive is different. It's got a new clutch in it but accelerates really slowly. I know the 5S isn't all that quick but this is not how I remember it being. Something is robbing my power and I'm not quite sure what it is. Anyways it rides pretty smooth. Suspension is pretty good, brakes were new, sounds like a bearing might be on its way out(shocker), and have a clunk every now and then but I'll fix it in time. The trunk cables were pretty messed up so they had a wire hanging out of the back to get into the trunk. Also have a few exhaust leaks.. One from around the manifold and another from I think the flex pipe but not exactly sure.. I planned on getting exhaust work done anyways. The engine is not original. Engine in the car now has only 127k but I can't say the same for the transmission. I have a little grocery list of problems to take care of but it serves great as a daily right now! Might be here a lot for some help as it's been a while since I've worked on one of these so if I say something dumb or don't seem to know what I'm talking about then I apologize!

Stand by for images as I figure out what source to use.. just look at the profile for pictures for now!

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: July 20th, 2018 - 8:54 PM