6G Celicas Forums

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Rear polybush problems
post Oct 19, 2016 - 6:08 AM
+Quote Post
rhodesyboy

Enthusiast
*
Joined Jun 11, '16
From lancashire
Currently Offline

Reputation: 0 (0%)




Hi basically I replaced all of my rear arms with powder coated ones from gt4 play fitted with polybushes and I have had some pretty sketchy moments, I like the handling in general but over certain bumps it feels like the rear is wobbling a bit and snaking around and then even more worryingly I have had the car randomly start snaking a few times on the motorway.
I have since read that you shouldn't polybush the no1 and no2 arms? Is that why I am having these issues and is it ok to keep the single trailing arm that runs parallel to the car polybushed, both on chassis side and hub side.
post Oct 19, 2016 - 10:06 PM
+Quote Post
Bitter

Enthusiast
*****
Joined Mar 11, '06
From Way South Chicago
Currently Offline

Reputation: 0 (0%)




Had it aligned afterward?


--------------------
post Oct 20, 2016 - 8:06 AM
+Quote Post
rhodesyboy

Enthusiast
*
Joined Jun 11, '16
From lancashire
Currently Offline

Reputation: 0 (0%)




Unfortunately no, the lobe had left a bit of an 'imprint' and lined it back up so I guess it could be off.
I was just thinking if people are saying not to polybush them so should I even bother getting the polybushed arms aligned or fit normal bushes and then get it aligned
post Oct 21, 2016 - 8:50 PM
+Quote Post
Bitter

Enthusiast
*****
Joined Mar 11, '06
From Way South Chicago
Currently Offline

Reputation: 0 (0%)




Get it aligned correctly and then see how it is.


--------------------

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: August 8th, 2020 - 9:58 PM